The max size of Request system collection file

requestsystem

(Jurgen) #1

Gonna use the request system for first time … and looking forward to it :wink: … what i regret is that the size of this request list is too small :slight_smile: but it would also be great that you can remove or even edit tracks when they are uploaded on slipmat and not tru traktor or other software


(Lauri) #2

Damn it, en voi lisätä uutta kettua tänne. Mites olisi jos laitetaan “on air”-linkit etusivulle?


(Jani) #3

Not sure if this belong in here as a reply for the post.
I’ve been struggling about my request list and it’s size.
413 Request Entity Too Large, how much is the quantity or size that can be uploaded?
Do you have any clue?

Thanks!


(Jani) #4

Found from the playlist converter the limit is only 256kb.


(Ville) #5

The current limit for Slipmat.io DJ request system collection file is ~2 MB, which is about 2000-3000 songs. (The limit is different for the Playlist Converter utility, don’t get confused with those :slight_smile:)

If you feel it’s super hard to limit the number of songs by manual selection, one easy way to cap the collection is to order your playlist by played count, end then take approx 2000 most played on that list as your collection file.

And, your audience of course can make free requests (requests that are not in the collection), too, so it’s not the end of the world if every single tune is not on your collection list :slight_smile:

The cap for the file is restricted because of technical reasons. If there’s a demand for much higher number of files, we can think about engineering the system a bit more to allow easier searching and browsing of huge collections.


(Jani) #6

Thanks for the reply!
Now I need to find out how the collection is made with Serato DJ. I got a .csv file and it seems it’s not a collection file. Is there any guide how to do it. on Serato’s page I couldn’t find it yet.

Edit: So I had to setup the BPM, Key and Artist rows to enabled and disable the rest and then export again. But I can’t get my BPMs and Key to show in the list :frowning:

Still exploring the solution